X-700 and 360PX

Discussion in 'Sony & Minolta' started by StevenC, Dec 7, 2017.

Tags:
  1. StevenC

    StevenC New Member

    Joined:
    Dec 7, 2017
    Messages:
    1
    Likes Received:
    0
    Hello all. I’m new here. I recently picked up an X-700. I had one years ago and traded it in when I switched to auto focus. Missed it ever since and was thrilled to get another one. It came with the multifunction back and motor drive 1. I also picked up the 360PX flash for it. Now here is the issue: when the flash is not in the hot shoe, it will test fire just fine. In the hot shoe, it will not fire and it will lock up the camera in all flash and camera modes when the power switch on the flash is on. If I shut the flash off, then the mirror returns and the shutter closes. It does this with or without the motor drive attached. I can’t imagine that it’s from testing without film in the camera. I do not have Cable OC to test it that way. I’m aware of capacitor problems locking up the shutter and film advance but it all works fine without the flash. I think it’s a flash issue but would greatly appreciate any feedback. Thanks!!!
     
  2. johnlouiscross

    johnlouiscross New Member

    Joined:
    Jan 9, 2008
    Messages:
    1
    Likes Received:
    0
    Hi Steve.
    I am just about to sell my X700 and lenses plus a 280 and 360 flash.
    If by chance you are in the UK and wanted a 360px on sale or return to confirm whether its camera or flash I am sure we could come to some arrangement.
    John
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice